Supporting vendors:
 
Your ad here?
 

Go Back   TeamKitfox Forums > Discussion > Engines

Reply
 
Thread Tools Display Modes
Old 09-13-2017, 02:00 PM   #1
mr bill
Senior Member
 
Join Date: Jul 2011
Location: milwaukee wi
Posts: 437
Default high oil temps and pressure

I have a 912 ULS. While flying last evening, oil temperature (230 F) and pressure (75 psi) both went to the top of the green and upon landing the oil pressure began fluctuating, but stayed within the green. CHT stayed in the middle of the green (205 F) all the while. All three temperatures normally stay in the middle of the green. Any ideas?
mr bill is online now   Reply With Quote
Old 09-13-2017, 03:41 PM   #2
Norm
Senior Member
 
Norm's Avatar
 
Join Date: May 2013
Location: Airdrie, North of Calgary
Posts: 276
Default Re: high oil temps and pressure

Quote:
Originally Posted by mr bill View Post
I have a 912 ULS. While flying last evening, oil temperature (230 F) and pressure (75 psi) both went to the top of the green and upon landing the oil pressure began fluctuating, but stayed within the green. CHT stayed in the middle of the green (205 F) all the while. All three temperatures normally stay in the middle of the green. Any ideas?
Check ground connections first. May be false readings.
__________________
Norm
Airdrie Ab, Can
North of Calgary
Flying SuperFox Model IV
Norm is offline   Reply With Quote
Old 09-13-2017, 05:58 PM   #3
mr bill
Senior Member
 
Join Date: Jul 2011
Location: milwaukee wi
Posts: 437
Default Re: high oil temps and pressure

Will do. Seems odd that they would both go high. Just got home from flying for another hour and the same thing happened by the end of the hour. After landing, both returned to the middle of the green.
mr bill is online now   Reply With Quote
Old 09-15-2017, 12:48 PM   #4
Wheels
Senior Member
 
Wheels's Avatar
 
Join Date: Oct 2010
Location: Spokane Wa
Posts: 275
Default Re: high oil temps and pressure

HI Mr Bill,
I don't fly a ULS, I fly a UL. But, that said, My neighbor's ULS was fluctuating and we looked at the ball and spring assembly in the lube pump per the Rotax Owner.com video on the same.
We found a small piece of PLASTIC from the oil cap ring on an oil bottle had come off during his last oil change and been poured into the engine oil reservoir. the plastic part made it all the way to the ball and spring assembly of the pump. We cleaned the ball and spring assembly and reinstalled it. Problem solved. He now uses a filtered funnel during servicing.
Just a thought.
Wheels is offline   Reply With Quote
Old 09-15-2017, 04:44 PM   #5
mr bill
Senior Member
 
Join Date: Jul 2011
Location: milwaukee wi
Posts: 437
Default Re: high oil temps and pressure

I am doing an oil /filter change tomorrow and will check that. I do have the latest screw plug, spring and plunger.

Thank you and Norm

Bill
mr bill is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 07:29 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.